Home > Unable To > E Unable To Correct Problems You Have Held Broken Packages. Ubuntu

E Unable To Correct Problems You Have Held Broken Packages. Ubuntu

Contents

Also, does sudo apt-get dist-upgrade show any available updates? –thomasrutter Nov 29 '12 at 1:59 2 I don't know what's wrong with your question, I don't see any actual error, Unfortunatly I now have no unity option. Not the answer you're looking for? The following packages have unmet dependencies: libc6 : Depends: libc-bin (= 2.13-20ubuntu5.3) libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.5) but 2.13-20ubuntu5.3 is installed Depends: libc-dev-bin (= 2.15-0ubuntu10.5) libmono-corlib4.0-cil : Depends: mono-runtime (>= http://popupjammer.com/unable-to/ubuntu-server-unable-to-locate-package-ubuntu-desktop.html

Done Building dependency tree Reading state information... deb http://in.archive.ubuntu.com/ubuntu/ trusty universe deb-src http://in.archive.ubuntu.com/ubuntu/ trusty universe deb http://in.archive.ubuntu.com/ubuntu/ trusty-updates universe deb-src http://in.archive.ubuntu.com/ubuntu/ trusty-updates universe ## N.B. How can I Change the store language after switching the store Is there a non-medical name for the curve where index finger and thumb meet? Kapat Evet, kalsın. check this link right here now

E Unable To Correct Problems You Have Held Broken Packages. Ubuntu

It makes it easy to resolve conflicts, especially when packages must be changed together due their relationships. nothing shows in broken...? deb http://in.archive.ubuntu.com/ubuntu/ trusty main restricted deb-src http://in.archive.ubuntu.com/ubuntu/ trusty main restricted ## Major bug fix updates produced after the final release of the ## distribution. What are the considerations for waterproofing a building's first few floors?

Using flags vs. Terms Privacy Security Status Help You can't perform that action at this time. You signed in with another tab or window. Apt-mark Showhold Now that I've done all of that, when I try to update the chroot to add the xiwi target, I can't.

Then do a system update and then try to upgrade the distribution. –NikTh Feb 4 '14 at 10:02 You are right, I did miss old-releases being substituted for archives. asked 1 year ago viewed 7432 times active 1 year ago Blog Stack Overflow Gives Back 2016 Developers, Webmasters, and Ninjas: What’s in a Job Title? I started having this error "E: Unable to correct problems, you have held broken packages." when I tried to reinstall Amarok through the terminal earlier, here's the script: Code: $ sudo http://askubuntu.com/questions/416196/unable-to-correct-dependencies Having a problem logging in?

Learn more You're viewing YouTube in Turkish. Apt List Held Packages In my case I was trying to install curl on ubuntu saucy salamander 13.10... You simply have to be aware of what it's suggesting and proceed only if it is a good idea. –thomasrutter Mar 12 '14 at 3:23 3 The "on hold" packages When hiking, why is the right of way given to people going up?

Packages Have Unmet Dependencies

Any magic that will allow me to get my package system straightened out? apt share|improve this question edited Aug 23 '14 at 2:30 Braiam 40.1k1696158 asked Nov 28 '12 at 23:48 trond 594253 3 It may help if you showed us the command E Unable To Correct Problems You Have Held Broken Packages. Ubuntu Done Some packages could not be installed. Apt-get Held Packages I want to go for a dual boot for Windows 7 now.

Sometimes cleaning things up will help, using: sudo apt-get autoclean Also, after a sudo apt-get update you can try 'fix'ing things with: sudo apt-get -f install Sign up for free http://popupjammer.com/unable-to/packages-have-unmet-dependencies.html Would you like to answer one of these unanswered questions instead? upgrade , update and fix - missing will remove the problem.sudo apt-get upgradesudo apt-get updatesudo apt-get update --fix-missingType the above 3 commands in Terminal. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out Unable To Correct Problems Held Broken Packages Debian

Default is now Gnome and unity-desktop will NOT reinstall. It –Zloy Smiertniy Jan 19 '15 at 11:45 add a comment| up vote 2 down vote I have also the same problem for sudo apt-get install npm. Oturum aç Paylaş Daha fazla Bildir Videoyu bildirmeniz mi gerekiyor? navigate here Done Building dependency tree Reading state information...

So I wonder if crouton is trying to re-install or update e17? Dpkg --get-selections | Grep Hold The following information comes from a simple google search on Unable to correct problems, you have held broken packages You can get a list of actual held packages with: Code: dpkg Geekurville 10.383 görüntüleme 7:51 How To Remove A Broken PPA From Ubuntu - Süre: 4:02.

For instance ia32-libs and skype (4.0).

Also, please note that software in ## multiverse WILL NOT receive any review or updates from the Ubuntu ## security team. I'd would recommend a new installation of Ubuntu 13.10, especially if you are running a server machine... All I did was sudo apt-get update and that fixed my issue. Unable To Correct Problems, You Have Held Broken Packages. Ros apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed.

Done Building dependency tree Reading state information... Commands are case sensitive, as is everything else in Linux, so often it's a good idea to copy a command and drop in into the Terminal to execute it, to avoid steez2002 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by steez2002 07-06-2014, 05:56 PM #6 jamison20000e Senior Member Contributing Member Registered: Nov his comment is here Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.

I would suggest trying the same thing you did but with aptitude install instead of apt-get install but I'm in no way an Ubuntu expert ;) Asuza commented Feb 20, 2016 By the way, to Paste into a Terminal window, the command is Ctrl-Shift-V, go figure. Thank you! However, aptitude might offer to go ahead, but uninstall a whole bunch of other packages in order to satisfy those conflicts - or even downgrade packages.

We recommend upgrading to the latest Safari, Google Chrome, or Firefox. jamison20000e View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by jamison20000e View Blog 07-14-2016, 02:12 PM #11 chaitanyauk LQ Newbie Registered: Jul It can all be done through synaptic, Last edited by Hakunka-Matata; February 8th, 2013 at 05:12 PM. You are currently viewing LQ as a guest.

I don't know what I should be looking for, everything is "checked" in the repositories options in Syaptic, but could it be something to do with my sources list?: PHP Code: Depends: apache2-utils but it is not going to be installed. Related 1Unable to upgrade due to “SystemError: E:Method has died unexpectedly!” error0Error : Unable to correct problems , you have held broken packages6Correct way to install virtual dependency1Ubuntu 13.10 won't update. share|improve this answer answered Sep 1 '15 at 16:09 dsh 8,61021631 Would you explain your preference in more detail so that I can take your approach? –Sam Sep 2

Kapat Daha fazla bilgi edinin View this message in English YouTube 'u şu dilde görüntülüyorsunuz: Türkçe. Do I just need to start completely over and try again? Has Darth Vader ever been exposed to the vacuum of space? Why is this 'Proof' by induction not valid?

There are some who question the need for "apt-get upgrade" when many times the solution involves invoking "apt-get dist-upgrade". USA Distribution: MINT Debian, Angstrom, SUSE, Ubuntu Posts: 4,137 Blog Entries: 10 Rep: Quote: Originally Posted by chaitanyauk I am getting the same issues.I tried everything that are mentioned earlier. For details and our forum data attribution, retention and privacy policy, see here Gezinmeyi atla TROturum açAra Yükleniyor...