Home > Error Unable > Error Unable To Execute Port Upgrade Xz Failed

Error Unable To Execute Port Upgrade Xz Failed

Chriss-MacBook:macports chris$ sudo port deactivate perl 'at'5.12.3_1+perl5_12 Error: port deactivate failed: Image error: port perl is not active. –blnak Oct 21 '11 at 3:10 You could try to force-uninstall Any suggestions on how to resolve this or how to install gcc46 for i386? (Previously asked and as of now unanswered on SuperUser.) macos macports share|improve this question asked Aug 18 Not the answer you're looking for? Please login or register in order to proceed. #3883Permalink Like [0] Dislike [0] Re: Mac 10.9 installation error Nov-15-13 19:06:30 Then don't use the +clang variant. check my blog

Can three +1/+1 counters be considered one +3/+3 counter? Error: emacsapp is not installed $ sudo port search emacs Password: Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'. $ sudo port upgrade Seemed it was having a hard time with 2.1.0. in any way. https://trac.macports.org/ticket/38472

Proceeding despite dependencies. ---> Deactivating libxml2 @2.9.1_0 ---> Unable to deactivate libxml2 @2.9.1_0, the following ports depend on it: ---> libcroco @0.6.8_0 ---> libgsf @1.14.30_0 ---> py27-libxml2 @2.9.1_1 ---> libxslt @1.1.28_0 current community blog chat Ask Different Ask Different Meta your communities Sign up or log in to customize your list. Depowering a high AC PC without killing the rest of the group Do counters combine? comment:10 Changed 4 years ago by ryandesign (Ryan Schmidt) Ok, please try again with the debug switch and see if that prints any more information: sudo port -d install ImageMagick comment:11

If not, how much of that path does exist? yes checking whether completion_matches is declared... How can I fix this? Do (did) powered airplanes exist where pilots are not in a seated position?

asked 5 years ago viewed 2862 times active 2 years ago Blog Stack Overflow Gives Back 2016 Developers, Webmasters, and Ninjas: What’s in a Job Title? Type "man sudo" for more information. I decided to run 'sudo port upgrade outdated' A quick warning about gperf not being found and bam, things were broken. Did you attempt to sudo port upgrade gettext? –prodigitalson Mar 13 '13 at 20:04 I tried sudo port selfupdate, and that worked fine.

Is this sentence 'I know him a teacher.' acceptable? x86_64-apple-darwin13.0.0 checking MacPorts version... 2.2.1 checking for sw_vers... /usr/bin/sw_vers checking for defaults... /usr/bin/defaults checking for xcode-select... /usr/bin/xcode-select checking Mac OS X version... 10.9 checking Xcode location... /Applications/Xcode.app/Contents/Developer checking Xcode version... 5.0.1 ANY CHANGES TO THIS FILE WILL BE LOST ON UNINSTALL/UPGRADES! > # Make your changes to /opt/local/etc/mysql55/my.cnf > # YOU HAVE BEEN WARNED! 3a5 > # MacPorts default options 5,20c7,9 < When I run it, it says I have the latest version.

Can a creature with multiattack make more than one attack as part of a readied attack? my site I am assuming that you had Xcode command line utils installed previously. All Rights Reserved. I still have the problem.

I'm starting with a simple 'sudo port install gkrellm' and I get: ### begin port output ######################################## Warning: The Command Line Tools for Xcode don't appear to be installed; most ports http://popupjammer.com/error-unable/error-unable-to-execute-mpasmwin-build-failed.html Then anyone can read it. comment:9 Changed 3 years ago by ryandesign (Ryan Schmidt) If you're going to use --with-no-root-privileges you probably need to set --with-install-user and --with-install-group too. edit after updating, this is the output.

comment:4 Changed 3 years ago by [email protected]… MacPorts is installed as non-root (the user that ran that command). These commands no longer work. I did install apple's command line tools, and ran port selfupdate, and port upgrade outdated. news printf :info:configure checking for gcc... /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang :info:configure checking whether the C compiler works...

Ask Different works best with JavaScript enabled Proceeding despite dependencies. ---> Cleaning dbus ---> Uninstalling dbus @1.8.6_0 ---> Cleaning dbus ---> Computing dependencies for dbus ---> Installing dbus @1.8.6_0 ---> Activating dbus @1.8.6_0 ############################################################################ # Startup items have Please run selfupdate again now that MacPorts base has been updated. [[email protected]] ~ $ sudo port upgrade outdated ---> Computing dependencies for libxml2 ---> Fetching archive for libxml2 ---> Attempting to

Make a list of your installed ports, and consider deleting /opt/local prior to installing.

in 2 days Blog Stack Overflow Gives Back 2016 Developers, Webmasters, and Ninjas: What’s in a Job Title? I interrupted the update, but it was too late. yes checking for Tcl configuration... Related 1Mac Ports keeps on re-installing Perl, Python, etc7Xcode appears to be installed but xcodebuild is unusable0MacPorts on mountain lion - cannot install apache2 due to gettext package1PHP exec() with Mac

share|improve this answer answered Feb 29 '12 at 14:04 Al Hombre 212 add a comment| up vote 0 down vote Try port selfupdate or port sync. Not the answer you're looking for? Server has decided that the best way to present this information is to hand me my homedir as /Network/Servers//Volumes/// rather than just the path in /Volumes. More about the author Not really sure why it was having a problem with expat 2.1.0 upgrade.

Attempting to install gnutar. Help, my office wants infinite branch merges as policy; what other options do we have? I followed Jens' advice and made a 'port upgrade outdated' but the missing dependencies still would exist. configure: error: rml headers not found even though rml-mmc was detected as a dependency and being built and installed by macports Update: Indeed, the rml package does not contain any headers

In what spot would the new Star Wars movie "Rogue One" go in the Machete Order? Warning: See http://guide.macports.org/chunked/installing.xcode.html for more information. ---> Computing dependencies for gkrellm ---> Dependencies to be installed: gtk2 atk gettext expat libiconv gperf ncurses glib2 libffi perl5 perl5.12 gdbm xz zlib gobject-introspection Link here: http://mxcl.github.com/homebrew/ As Randy suggested, getting Brew up and running was a lot easier than using MacPorts.